Vulnerability in tapestry-core in Apache Tapestry 5.5.0+ on all platforms allows attackers to download clsspath assets via specially crafted URLs. Users are recommended to upgrade to version 5.9.1, which fixes this issue.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://lists.apache.org/thread/6j3yojqrdsxkrfz52d0zjyrf5n9xttmw Vendor Advisory, Mailing List
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 7.5 · apacheNVD modified 2026-10-23 20:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:tapestry:*:*:*:*:*:*:*:*
References 2
- https://lists.apache.org/thread/6j3yojqrdsxkrfz52d0zjyrf5n9xttmw Vendor Advisory, Mailing List
- http://www.openwall.com/lists/oss-security/2026/08/08/2 Mailing List, Third Party Advisory