Improper Handling of Insufficient Permissions or Privileges vulnerability in Apache Kylin. Improper authorization in job information retrieval, where an attacker may get access to unauthorized jobs in other projects. This issue affects Apache Kylin: from 4 through 5.0.3. Users are recommended to upgrade to version 5.0.4, which fixes the issue.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://lists.apache.org/thread/xg8dcyjw0nkq5y8dhq3r25x3rxc62x9j Mailing List, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 4.3 · apacheNVD modified 2026-10-24 21:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:kylin:*:*:*:*:*:*:*:*
References 2
- https://lists.apache.org/thread/xg8dcyjw0nkq5y8dhq3r25x3rxc62x9j Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/07/14/6 Mailing List, Third Party Advisory