REDAXO is a PHP-based content management system. Prior to 5.21.2, rex_api_install_package_update in redaxo/src/addons/install/lib/api/api_package_update.php inherits the false default from rex_api_function::requiresCsrfProtection() instead of requiring a CSRF token. An unauthenticated attacker can cause a logged-in administrator's browser to request a selected package update from the configured REDAXO package server, changing installed addon code or disrupting the site without the administrator's intent. This issue is fixed in version 5.21.2.
Fix
Patch, vendor advisory and mitigation references on NVD 4
- https://github.com/redaxo/core/commit/a13abbffbad4fdea46a4edc86cdba3335ca9e8f3 Patch
- https://github.com/redaxo/core/pull/6579 Issue Tracking, Patch
- https://github.com/redaxo/core/security/advisories/GHSA-m8r3-22v6-g877 Exploit, Vendor Advisory
- https://github.com/redaxo/core/security/advisories/GHSA-m8r3-22v6-g877 Exploit, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 6.4 · redaxoNVD modified 2026-10-19 20:35
Affected (CPE criteria) 1
cpe:2.3:a:redaxo:redaxo:*:*:*:*:*:*:*:*
References 5
- https://github.com/redaxo/core/commit/a13abbffbad4fdea46a4edc86cdba3335ca9e8f3 Patch
- https://github.com/redaxo/core/pull/6579 Issue Tracking, Patch
- https://github.com/redaxo/core/releases/tag/5.21.2 Release Notes
- https://github.com/redaxo/core/security/advisories/GHSA-m8r3-22v6-g877 Exploit, Vendor Advisory
- https://github.com/redaxo/core/security/advisories/GHSA-m8r3-22v6-g877 Exploit, Vendor Advisory