Improper Isolation or Compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy class containing untrusted code bypassing the Groovy security sandbox. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.6, from 4.1.0-M0 through 4.1.1. Users are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue by tightening the Groovy security sandbox.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://lists.apache.org/thread/2236mlm6hbvs6g16yqz5y9s8bb7q1lo1 Mailing List, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 9.8 · apacheNVD modified 2026-10-24 20:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:syncope:*:*:*:*:*:*:*:*
References 2
- https://lists.apache.org/thread/2236mlm6hbvs6g16yqz5y9s8bb7q1lo1 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/07/20/11 Mailing List, Third Party Advisory