UnixAuth lacks brute-force protection in Apache Ranger versions <= 2.8.0. Note: UnixAuth is NOT a recommended option for production deployments. Users are recommended to upgrade to version 2.9.0, which fixes this issue.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://lists.apache.org/thread/cx53rbkxkn5hbvzv8ohwvndzrxhc06qf Mailing List, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 7.3 · apacheNVD modified 2026-10-23 20:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:ranger:*:*:*:*:*:*:*:*
References 2
- https://lists.apache.org/thread/cx53rbkxkn5hbvzv8ohwvndzrxhc06qf Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/08/09/11 Mailing List, Third Party Advisory