Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket. This issue affects Apache Wicket: from 9.0.0 through 9.23.0, from 10.0.0 through 10.9.0. Users are recommended to upgrade to version 10.10.0, which fixes the issue.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://lists.apache.org/thread/67814fo0zocv3161bk1cr0ypvrkxky43 Mailing List, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 6.1 · apacheNVD modified 2026-10-24 13:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:wicket:*:*:*:*:*:*:*:*
References 2
- https://lists.apache.org/thread/67814fo0zocv3161bk1cr0ypvrkxky43 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/07/27/4 Mailing List, Third Party Advisory