A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service. This issue affects Apache Qpid ProtonJ2: through 1.1.0. Users are recommended to upgrade to version 1.2.0, which fixes the issue.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://lists.apache.org/thread/kmov6k7f3moqy01m1s370fl61vgos3ly Mailing List, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 7.5 · apacheNVD modified 2026-10-23 21:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:qpid_protonj2:*:*:*:*:*:*:*:*
References 2
- https://lists.apache.org/thread/kmov6k7f3moqy01m1s370fl61vgos3ly Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/08/04/29 Mailing List, Third Party Advisory