It was not possible to govern the rate at which the broker would respond to an echo flow, enabling an authenticated attacker to cause excessive resource usage and potential denial of service. This issue affects Apache Qpid Broker-J: through 10.0.1. Users are recommended to upgrade to version 10.1.0, which fixes the issue.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://lists.apache.org/thread/tcnrv5nhmnsrzz92o4owxgycro6llt57 Mailing List, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 6.5 · apacheNVD modified 2026-10-23 21:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:qpid_broker-j:*:*:*:*:*:*:*:*
References 2
- https://lists.apache.org/thread/tcnrv5nhmnsrzz92o4owxgycro6llt57 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/08/04/20 Mailing List, Third Party Advisory