Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Johnzon. ClassConverter loads & static-initializes an attacker-named class from untrusted JSON. This issue affects Apache Johnzon: from 1.0.0 before 2.2.0. Users are recommended to upgrade to version 1.3.1 (javax namespace) or 2.2.0 (jakarta specification namespace), which fixes the issue.
Fix
Nothing published yet: no patch, vendor advisory or mitigation reference on NVD, no vendor advisory in the News for this CVE, not in CISA's KEV, no fixed package version. BaselineWatch does not guess at one.
Change history 5
- StatusPublished → DeferredNVD modified 2026-10-20 20:17
- CVSS9.8 (v3.1, CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)NVD modified 2026-10-20 20:17
- StatusDeferred → PublishedNVD modified 2026-10-19 10:36
- StatusReceived → DeferredNVD modified 2026-10-19 20:47
- First seenunscoredNVD modified 2026-10-19 11:17
Affected (CPE criteria) 0
NVD has not attached CPE configurations yet.