Flowise (packages flowise and flowise-components) in versions <= 3.1.2 contain a sandbox escape in the vm2/@flowiseai/nodevm JavaScript sandbox. An authenticated user with access to the /api/v1/node-custom-function endpoint can escape the sandbox by supplying attacker-controlled executablePath and args parameters to puppeteer.launch(), which internally invokes child_process.spawn() outside the sandbox boundary. This allows execution of arbitrary OS commands as the Flowise process user (root in the official Docker image) and arbitrary host file disclosure via Chromium's file:// URL handling. In versions 3.0.8–3.1.2 exploitation requires ALLOW_BUILTIN_DEP=true; earlier versions are exploitable by default. Fixed in 3.1.3.
Fix
Patch, vendor advisory and mitigation references on NVD 2
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-9gvv-qjj3-2p6g Exploit, Mitigation, Vendor Advisory
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-9gvv-qjj3-2p6g Exploit, Mitigation, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 9.4 · flowiseaiNVD modified 2026-10-23 19:10
Affected (CPE criteria) 1
cpe:2.3:a:flowiseai:flowise:*:*:*:*:*:*:*:*
References 3
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-9gvv-qjj3-2p6g Exploit, Mitigation, Vendor Advisory
- https://www.vulncheck.com/advisories/flowise-before-sandbox-escape-via-puppeteer Third Party Advisory
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-9gvv-qjj3-2p6g Exploit, Mitigation, Vendor Advisory