CodeWhale versions >= 0.8.41 and < 0.8.64 contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content the agent ingests (a fetched page, MCP result, or repo file) can cause commands to run at the privilege level of that approved process. Fixed in 0.8.64.
Fix
Nothing published yet: no patch, vendor advisory or mitigation reference on NVD, no vendor advisory in the News for this CVE, not in CISA's KEV, no fixed package version. BaselineWatch does not guess at one.
Change history 1
- First seenCVSS 7.3NVD modified 2026-10-22 22:10
Affected (CPE criteria) 0
NVD has not attached CPE configurations yet.
References 4
- https://github.com/Hmbown/CodeWhale/commit/57f3c89471e27ac4032d9791f6885e5d4408c381
- https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-g29h-pfmp-qp9r
- https://www.vulncheck.com/advisories/codewhale-before-privilege-escalation-via-exec-shell-interact
- https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-g29h-pfmp-qp9r