BaselineWatch
Desk

CVE-2026-8145

5.4 medium SSVC exploitation: none Deferred

The WholesaleX – B2B & Wholesale Plugin for WooCommerce with Wholesale Prices plugin for WordPress is vulnerable to Limited Privilege Escalation in all versions up to, and including, 3.0.8 via the 'process_registration' due to missing validation on the 'wholesalex_registration_role' parameter. This makes it possible for unauthenticated attackers to register as any existing WholesaleX role. The vulnerability was partially patched in version 2.3.8.

Fix

Nothing published yet: no patch, vendor advisory or mitigation reference on NVD, no vendor advisory in the News for this CVE, not in CISA's KEV, no fixed package version. BaselineWatch does not guess at one.

Change history 2

  1. StatusReceived → DeferredNVD modified 2026-10-15 14:45
  2. First seenCVSS 5.4NVD modified 2026-10-15 12:16

Affected (CPE criteria) 0

NVD has not attached CPE configurations yet.

References 5