Backstage is an open framework for building developer portals. Prior to 0.3.25, the @backstage/plugin-scaffolder-backend-module-confluence-to-markdown package is affected by improper input validation in confluence to markdown scaffolder module. Insufficient input validation in the Confluence to Markdown scaffolder module could allow an attacker to influence file write operations during template execution. Exploitation requires a Backstage user to run a template that processes attacker-influenced Confluence content. This issue is fixed in version 0.3.25.
Fix
Patch, vendor advisory and mitigation references on NVD 3
- https://github.com/backstage/backstage/commit/506c2c11bce3ed9d1f8f50de5d6474b16e43a65e Patch
- https://github.com/backstage/backstage/releases/tag/v1.54.6 Patch, Release Notes
- https://github.com/backstage/backstage/security/advisories/GHSA-75qf-886x-5xf2 Mitigation, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 6.5 · linuxfoundationNVD modified 2026-10-16 15:11
Affected (CPE criteria) 2
cpe:2.3:a:linuxfoundation:backstage\/plugin-scaffolder-backend-module-confluence-to-markdown:*:*:*:*:*:node.js:*:*cpe:2.3:a:linuxfoundation:backstage:*:*:*:*:*:*:*:*