Packer up to 1.15.4 is vulnerable to an issue in the third-party plugin installer that may allow unintended file system modification and could lead to code execution. A user who installs a plugin from a malicious or compromised source may be affected. This vulnerability (CVE-2026-19589) is fixed in Packer 1.16.0.
Fix
Vendor advisories in the News 1
- HCSEC-2026-29 - Packer vulnerable to arbitrary file write via crafted plugin archive during installation HashiCorp security bulletins · 2026-08-17
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 7.1NVD modified 2026-10-23 16:10
Affected (CPE criteria) 0
NVD has not attached CPE configurations yet.