Russh is a Rust SSH client & server library. Prior to version 0.60.1, a pre-authentication denial-of-service vulnerability exists in the server's keyboard-interactive authentication handler. A malicious client can crash any russh-based server that implements keyboard-interactive auth (e.g., for 2FA/TOTP) with a single malformed packet, requiring no credentials. This issue has been patched in version 0.60.1.
Fix
Patch, vendor advisory and mitigation references on NVD 3
- https://github.com/Eugeny/russh/commit/6c3c80a9b6d60763d6227d60fa8310e57172a4d1 Patch
- https://github.com/Eugeny/russh/security/advisories/GHSA-f5v4-2wr6-hqmg Exploit, Mitigation, Vendor Advisory
- https://github.com/Eugeny/russh/security/advisories/GHSA-f5v4-2wr6-hqmg Exploit, Mitigation, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 7.5 · russh_project, warpgate_projectNVD modified 2026-10-26 18:10
Affected (CPE criteria) 2
cpe:2.3:a:russh_project:russh:*:*:*:*:*:rust:*:*cpe:2.3:a:warpgate_project:warpgate:*:*:*:*:*:*:*:*
References 4
- https://github.com/Eugeny/russh/commit/6c3c80a9b6d60763d6227d60fa8310e57172a4d1 Patch
- https://github.com/Eugeny/russh/releases/tag/v0.60.1 Product, Release Notes
- https://github.com/Eugeny/russh/security/advisories/GHSA-f5v4-2wr6-hqmg Exploit, Mitigation, Vendor Advisory
- https://github.com/Eugeny/russh/security/advisories/GHSA-f5v4-2wr6-hqmg Exploit, Mitigation, Vendor Advisory