A vulnerability has been found in Cesanta Mongoose up to 7.20. This affects the function mg_tls_recv_cert of the file mongoose.c of the component TLS 1.3 Handler. Such manipulation of the argument pubkey leads to heap-based buffer overflow. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.21 mitigates this issue. The name of the patch is 0d882f1b43ff2308b7486a56a9d60cd6dba8a3f1. It is advisable to upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
Fix
Patch, vendor advisory and mitigation references on NVD 1
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 5.5 · cesantaNVD modified 2026-10-26 22:10
Affected (CPE criteria) 1
cpe:2.3:a:cesanta:mongoose:*:*:*:*:*:*:*:*
References 6
- https://github.com/cesanta/mongoose/ Product
- https://github.com/cesanta/mongoose/commit/0d882f1b43ff2308b7486a56a9d60cd6dba8a3f1 Patch
- https://github.com/cesanta/mongoose/releases/tag/7.21 Product, Release Notes
- https://vuldb.com/submit/770063 Exploit, Third Party Advisory, VDB Entry
- https://vuldb.com/vuln/354825 Third Party Advisory, VDB Entry
- https://vuldb.com/vuln/354825/cti Permissions Required, VDB Entry